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Lesson 24
Drafting Standards

Learning Objectives
At the conclusion of this lesson, the user will be able to:

♦  Create templates defining custom drafting standards
♦  Copy one drafting standard to another
♦  Modify drafting standards

Drafting Standards allow the user to set up standards for parts, assemblies and drawings.  Standards control
linetype, units, colors, etc.

The Standards are set up under the Format Menu.

The Drafting Standards set up the drafting standards for the active drawing or template. You can apply a
drafting standard to the drawing, modify an existing standard, or create a custom standard based on an
existing standard.

When you create a new drawing, it is automatically assigned an active drafting standard that controls the
format for dimensions, text, line weights, terminators, and other elements that are dictated. You can use the
default standard, select from another named standard (ANSI, BSI, DIN, GT, ISO, or JIS), or customize a
standard to meet your own requirements.

In an Autodesk Inventor drawing, drafting standard settings also include elements that are not part of the
named standard, such as naming conventions for sheets and views, display color for elements on the
drawing sheet, format for the parts list, and selection of the special characters and symbols for annotations.

You can change any of the elements controlled by the drafting standard. By customizing an existing
standard or developing your own standard, you can enforce company conventions or optimize your
working environment.

TIP:  The Drafting Standards apply to the active drawing only.  If you have several drawing files
open simultaneously, each file can have a different standard in effect.
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When you customize the drafting standard in a drawing, the changes apply only to that drawing. To make
customized standards available in all new drawing files, make the changes in the template that you use to
create new drawings. Set the customized standard as the active standard in the template, so that it is
automatically set as the active standard in all new drawings.

If you use several drafting standards, you can customize all of them in a single template file and select the
active standard when you create a new drawing.  As an alternative, you can create different template files,
customizing a single standard in each one.

The active drafting standard controls many attributes of a drawing. You can create a custom drafting
standard based on an existing drafting standard.

1. Open a drawing or template file.

2. Select Format>Standards to open the Drafting Standards dialog box.

3. Click the prompt at the end of the list of standards.

4. In the New Standard dialog box, enter the name of the custom standard and select the base
standard.

5. In the Drafting Standards dialog box, click the More button to open and change specific attributes
of the custom standard.

The active drafting standard in a drawing or template file controls many defaults and options. In addition to
the elements that are dictated by ANSI, DIN, ISO, and JIS standards, the Drafting Standards dialog box
contains many default values an options that you can change.

•  Display color for sheets, lines, and other elements.

•  Naming conventions for views and sheets.

•  Formats for dimension values

•  Symbols and options available for drawing annotations.

•  Default format for parts lists.

•  Default balloon style

TIP:  The best method to manage Drafting Standards is to create template files with the desired
standards defined and use these templates when starting a new drawing.
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Creating a Part Template
To create a part template:

All new part files are created with a template. You can create your own templates and add them to the
templates provided by Autodesk Inventor.

1. Create a new part, using an existing template.

             

2. Set the default units of measurement.  Go to Format->Dimensions or use File->Properties.

These both bring up the same dialog box.

Go through each tab and set it up to the defaults you would like for most parts you work on.
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3.  If needed, change the grid setting and the sizes of the origin work planes to better accommodate
the average part size.

4. Create any work features, sketches, or geometry that will be included in every new part file.

5. Define commonly used parameters or link to a spreadsheet of parameters.

6. Save the file in the Autodesk\Inventor<version>\Templates folder or a subfolder of Templates. A
part file automatically becomes a template when it is saved to the Templates folder.

Then the next time you use File->New, you can access your custom part template.

TIP:  The file standard.ipt in the Templates folder is the default part template. To replace the
default template, remove standard.ipt and replace it with a template that has the same name.
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Creating a Drawing File Template

To create a drawing file template, open a standard drawing file.  Set up your sheets, borders, and title
blocks.  Be sure to include multiple sheets in the event your drawing will have more than one page.    Use
Tools->Options->Common to set the font to be used in dimensions.  Use Format->Standards to set the units
and Dimension Values.  Use File->Properties to set any defaults for property fields to be used in the Title
Block.

TIP:  To add tabs to the New dialog box, create new subfolders in the Templates folder and add
template files to them. The New dialog displays a tab for each subfolder in the Templates folder.

TIP:  You can only access templates (and the start-up dialog) using the File->New menu.  If you
bypass the start-up dialog by using the pull-down tool, the new file uses the templates that begin
with standard.  If you wish to by-pass the start-up dialog, but use custom settings, save your
templates as standard.ipt, standard.idw or standard.ipn in the templates directory.   It is a good
idea to save the original standard.* files in a back-up directory in case you are unhappy with the
results.
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Check List for Creating a Custom Drawing Template:
Title Block for Sheet 1
Title Block for Sheet 2
Border for Sheet 1
Border for Sheet 2
Special Symbols defined under Sketched Symbols
File Properties set for Drawing (File->Properties) ; set Author, Company Name, etc.
Colors set for Drawing (Format->Standards->Common)
Dimension Values set for Drawing (Format->Standards->Dimension Value)

Once you have the drawing file set up to your specifications, select File->Save Copy As.

You can set any template to be the default template for creating new drawings. To make a template the
default, save it in the Templates folder with the file name standard.idw. To avoid overwriting the existing
default template, move or rename the existing standard template before saving the new template.

Files that reside in the Templates folder appear on the Default tab of the New dialog box when you create
new files. Files that reside in a subfolder of the Templates folder appear as other tabs in the New dialog
box.
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Your custom drawing template now appears in the Start Up dialog.

Drafting Standards can only be accessed inside of drawing files, not part files.

The Drafting Standards dialog has the following tabs:

♦  Common
♦  Sheet
♦  Terminator
♦  Dimension Style
♦  Centermark
♦  Weld Symbol
♦  Surface Texture
♦  Control Frame
♦  Datum Target
♦  Hatch
♦  Balloon
♦  Parts List
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Dimension Style

Sets the default display characteristics for dimension and tolerance values and defines which characters will
be available to use in dimension text
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Common

The default text attributes and line styles in a drawing are defined by the active drafting standard.

Text Sets the default text. Select the type face and size from the drop-down lists. Click to apply bold, italic, or underline to the
default text, if desired.

Projection Sets the projection angle for drawing views. Click the appropriate button to choose first-angle or third-angle projection.

Units

Sets the measurement options for the drawing or template.

Linear Sets the units of measurement. Click the arrow and select from the list.

Decimal Marker Specifies the character to use as a decimal. Click the arrow and select from the list.

Line Weight

Sets line weights and scale that are available in the drawing or template file.

Value Specifies the line weights that are available to assign to the various line styles in the selected drafting standard.
Click the arrow to view a list of the existing weights. To add a line weight, enter the value.

Scale Sets the scale of all line styles in the drawing or template file.

Styles

Sets the line weight and other attributes for the lines in the drawing.

Style Selects a line style to edit. Click to select a style.

Line Type sets the line type for the selected line style. Click the arrow and choose from the list.

Line Weight sets the weight of the selected line style. Click the arrow and choose the weight from the list. To add a line
weight to the list, enter it in the Line Weight Value edit box.

Color Sets the color for the selected line style. Click the color button and choose the desired color from the Color dialog
box.

On the Common tab, set the text format, define the line weight, and assign the line type and color for each
line style.  To change the color, pick the button on the far right next to the scroll bar.  A color dialog will
appear that allows the user to select a new color.
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Pressing the Define Custom Colors buttons expands the color dialog box so that the user can create his own
colors to be assigned to various geometries.

The user can assign any desired color to various lines and geometries.
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Centermark

Mark Sets the size of the center indicator mark.
Gap Sets the gap distance between the center indicator and the extension line.
Extension Sets the minimum length of center mark extension lines.

Overshoot Sets the distance that center mark extension lines extend beyond the edges of the features
that they define.

Fictitious
Diameter Sets the size of center marks for suppressed pattern features.
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Surface Texture

Sets the display characteristics for surface texture symbols and the options in the Surface Texture Symbol
dialog

Symbol Available only when creating or editing a custom standard. Sets the size of the
machining-prohibited symbol. Click the button to switch between the options.

All Around

Available only when creating or editing a custom standard based on DIN, ISO, or JIS.
Adds the All Around symbol button to the Surface Texture Symbol dialog box. Select the
box to add the button to the dialog box; clear the check box to remove the button from the
dialog box.

Multiline
Available only when creating or editing a custom standard based on DIN or ISO. Sets the
symbol to accommodate two line of notes. Select the check box to use two lines; clear the
check box to use one line.

Force Tail Sets the default for the Force Tail option in the Surface Texture Symbol dialog box.
Select the check box to set the default to On; clear the check box set the default to Off.

Direction of
Machining Lay

The selection box specifies the machining lay options that will be available in the Surface
Texture Symbol dialog box. Select a check box to use a symbol; clear the check box to
make a symbol unavailable.

TIP:  If you turn off a symbol that is already used in a drawing, the existing symbols will continue to
display, but the symbol will not be available when new symbols are added.
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Weld Symbols

Sets the display characteristics for welding symbols and defines which welding symbols will be available to
use in the drawing or template.

Identification
Line

Sets the format for displaying a welding symbol identification line. If the selected standard
is based on ANSI or JIS, this option is not available.

Line Type sets the line style, such as dashed, dotted, or continuous. Click the arrow and
select the style from the list.

Gap sets the distance between the line and the welding symbol. Enter the distance.

Weld Symbols

Specifies which symbols will be available to use in the drawing.

Show Symbols For selects the symbol set that is listed in the selection box below. Click the
arrow and select a symbol set from the list.

The selection box specifies the symbols that will be available in the Welding Symbols
dialog box. Select a check box to use a symbol; clear the check box to make a symbol
unavailable.

TIP:  If you turn off a symbol that is already used in a drawing, the existing symbols will continue to
display, but the symbol will not be available when new symbols are added.
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Control Frame

Sets the display characteristics for feature control frames and defines which symbols will be available to
use in the drawing or

Merge

Specifies whether to combine cells when their data is the same. Click a button to
alternate between merging and separating the cells.

Symbol combines the cells if they contain the same symbol.

Tolerance combines cells if they contain the same tolerance.

Datum combines the cells if they reference the same datum.

End Padding Adds space to short cells so that pairs of cells align vertically.

White Space
Sets the space before and after text in the tolerance and datum cells. Enter the
amount of white space in the box. Click the button to alternate between padding
and no padding.

Geometric Dimensioning
and Tolerancing

Specifies which symbols will be available in the Feature Control Frame dialog
box.

Show Symbols For selects the symbol set that is listed in the selection box. Click
the arrow and select a symbol set from the list.

The selection box specifies the symbols that will be available in the Feature
Control Frame dialog box. Select a check box to use a symbol; clear the check
box to make a symbol unavailable.

TIP:  If you turn off a symbol that is already used in a drawing, the existing symbols will continue to
display, but the symbol will not be available when new symbols are added.
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Balloons

Use the Balloon tab in the Drafting Standards dialog box to set the style for the balloons you will add to a
drawing, and the level of components to include when using automatic ballooning.

Balloon Specifies the default balloon style for the drawing or template. Click to select the desired style.

Level

Sets the default number of levels of components to include when automatically adding balloons to
a view. Select the desired level.

First-Level Components Creates balloons for only the top level of components of the assembly in
the selected view. Balloons are added for subassemblies and parts that are not part of a
subassembly, but not for the parts in the subassemblies.

Only Parts Creates balloons for all parts of the assembly in the selected view. Balloons are not
created for the subassemblies, but are created for the parts in the subassemblies.

1. Select Format>Standards to open the Drafting Standards dialog box.

2. Select the drafting standard to change.

3. Click the More button to expand the dialog box and then click the Balloon tab.

4. Click the balloon style to use.

5. Set the level of components to include when automatically ballooning all of the components in a
drawing view.
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Parts List

Use the Parts List tab in the Drafting Standards dialog box to set up the format for the parts lists you will
add to a drawing.

1. Select Format>Standards to open the Drafting Standards dialog box.

2. Select the drafting standard to change.

3. Click the More button; button to expand the dialog box and then click the Parts List tab.

4. Set the sort order, title, heading, and other attributes of the parts list.

5. Click the Column Chooser button to open a dialog box and define the columns for the parts list.
Output
Direction

Specifies the default display direction for the parts list. Click the appropriate button to display the list from the bottom
up or the top down.

Lines of Text Sets the line spacing for each row in the parts list. Click the arrow and select the desired height.
Row Gap Sets the vertical space between the text and the cell frame. Enter the desired space in the box.

Heading

Specifies the format for the parts list heading.
Insert On sets the location of the column headings. Click to choose Top, Bottom, or None.
Heading Gap sets the vertical spacing between the heading text and the cell frame. Enter the desired space in the box.
Title specifies the title for the parts list. Enter the title in the box. If the box is empty, the parts list will not have a title.

Column

Specifies the format and content of the columns.

Opens the Column Chooser dialog box so that you can select the columns to include in the parts list.

Opens the Row Keys dialog box so that you can select properties other than the part number to display a part as a
separate item in the parts list.

Property
Displays the properties included in the parts list. To add or remove properties, or to change the order of columns, Click
the Column Chooser.

Column
Displays the heading names for the columns in parts lists. To change a name, select the current heading and enter the
new name.

Width
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Sets the default width for each column. To change the width of a column, select the cell and enter the new width.
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Sheet

Sets the default labels for sheets and views, and sets the colors for elements on sheets in a drawing or
template.

Labels
Sets the default labels assigned to new sheets and views in the drawing browser. As a new
sheet or view is added, the label is used with an incremented number (for example, Sheet1,
Sheet 2, Sheet3). Click in the box and enter the label.

Colors Sets the display colors for elements of the sheet. Click a color button to open the Color dialog
box and select the color for the associated element.

Sheet Color Sets the background color for the sheet. The color of views, symbols, and other elements does
not change; so set a background color that will provide good contrast.

Sheet Outline
Color Sets the outline color for the sheet.

Highlight
Color Sets the color of highlighted elements (when the cursor passes over them).

Selection
Color Sets the color of selected elements.
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Datum Target

Sets the display characteristics for datum target

Target Point

Sets the characteristics of datum target points.

Size sets the size of the target points. Enter the desired size in the box.

Color specifies the color of the target points. Click the color button to display the Color
dialog box and choose the color.

Area Hatch

Sets the characteristics of the datum target hatch pattern.

Distance sets the spacing between hatch lines. Enter the distance in the box.

Angle sets the angle of the hatch for rectangular and circular datum target symbols. Enter
the angle in the box.

Hidden Leader
Line Type

Sets the line style for hidden leader lines. Click the arrow and select a line type from the
list.

Boundary Line
Type Sets the line style for boundary lines. Click the arrow and select a line type from the list.

Draw Arrowhead
Specifies the default termination for datum target symbols. Select the check box to use an
arrowhead for datum targets; clear the check box to create datum target symbols without
an arrowhead.
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Hatch

Sets the default attributes for section view hatch patterns.

Pattern Specifies the basic pattern for the hatching. Click the arrow and choose the desired hatch pattern
from the list.

Line
Weight Sets the thickness of the hatch lines. Click the arrow and choose the thickness from the list.

Shift Shifts the hatch pattern to offset it slightly from the hatch pattern on a different part. Enter the
distance for the shift.

Angle Sets the angle for the hatch, relative to the view projection line. Enter the desired angle.

Scale
Sets the distance between lines in the hatch. A scale of 1 uses the distance specified in the
drafting standard, a scale of 1:2 will result in line spacing that is one half that specified in the
drafting standard.

Color Left picking on the color rectangle brings up a color dialog where the user can set the color for
hatch patterns.

Double
Creates a copy of the specified hatch pattern perpendicular to the first hatch pattern to a create
crosshatch. Select the check box to create the crosshatch; clear the check box to use only the
hatch pattern.

Hatches Specifies the hatch patterns that will be available when modifying the hatch in a section view.
Select a pattern to make it available; clear the check mark to make it unavailable.
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Dimension Style

To create a Dimension Style, go to Format->Dimension Style.

Linear

Sets the style for linear dimension values.

Format sets the dimension format to either decimal or fraction. Click the arrow and select from the list.

Precision sets the number of decimal places. Dimensions are truncated and rounded to the specified precision. Enter the
number of decimal places.

Leading Zeros adds a zero in front of dimension values less than 1 (for example 0.125). Select the check box to use leading
zeros; clear the check box to suppress leading zeros.

Trailing Zeros adds trailing zeros when needed to achieve the number of decimal places set in Precision (for example
1.000). Select the check box to use trailing zeros; clear the check box to suppress trailing zeros.

Angular

Sets the format for angular dimension values.

Format sets the dimension format to Decimal Degrees or Deg-Min-Sec.

Precision sets the number of decimal places. Dimensions are truncated and rounded to the specified precision. Enter the
number of decimal places.

Leading Zeros adds a zero in front of dimension values less than 1 (for example 0.125). Select the check box to use leading
zeros; clear the check box to suppress leading zeros.

Trailing Zeros adds trailing zeros when needed to achieve the number of decimal places set in Precision (for example
1.000). Select the check box to use trailing zeros; clear the check box to suppress trailing zeros.

Characters The selection box specifies the special characters that will be available to use in the Text Format dialog box. Select a check
box to use a character; clear the check box to make a character unavailable.
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Display

Sets the display characteristics for dimension

Dimension
Line

Sets the optimum offset and spacing for dimension lines. Enter the desired lengths in the
boxes.

Part Offset specifies the distance from an edge or point to the point where the placement
indicator displays as you place dimensions.

Spacing specifies the distance between the points where the placement indicator displays as
you place dimensions.

Extension Line

Sets the gap and length for extension lines. Enter the values in the boxes.

Origin Offset sets the size of the gap between the edge of the object being dimensioned and
the beginning of the extension line.

Extension sets the distance that the extension line extends past the dimension line.
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Text

Appearance Sets the font, size and style for dimension text.

Text Position

Sets the position for dimension text.

Orientation sets the vertical placement of the text relative to the dimension line. Click the
arrow and choose the placement from the list.

Gap sets the distance between the dimension line and the text. Enter the distance in the box.
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Prefix/Suffix

Assigns a value that will appear either before/above and after/below the dimension.

Terminator

The Terminator tab controls arrowhead styles to be used.

Defines the arrowheads used in the drawing or template.

General Sets the default arrowhead style for the drafting standard. Click the arrow and select the desired
style from the list.

Aspect Sets the aspect ratio or angle of the arrowhead relative to the associated line. Enter the desired
value.
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Tolerance

Method Sets the tolerance style
Linear Precision Sets the decimal places for the tolerance linear dimension.
Angular Precision Sets the decimal places for the tolerance angular dimension.
Text Size Sets the text size of the tolerance text
Suppression Enables/disables leading and/or trailing zeros.
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Options

Method Sets the default appearance for extension lines
Type Sets the default dimension to be applied
Options Sets the default appearance for arrowheads.
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Review Questions

1. True or False

Drafting Standards set up standards for parts, assemblies and drawings.

2. True or False

If you have more than one file open at a time, they all must use the same Drafting Standard.

3. To set up the background color for a drawing sheet:

A. File->Properties->Custom
B. Tools->Options->Drawing
C. Format->Standards->Sheet
D. Sheet->Edit

4. To set up the number of decimals to be used in dimensions:

A. File->Properties->Units
B. Tools->Options->Design Elements
C. Format->Standards->Dimension Value
D. Format->Dimension Style->Units

5. To set up the color of dimension text to be used in drawings:

A. File->Properties->Units
B. Tools->Options->Colors
C. Format->Standards->Dimension Value
D. Format->Dimension Style->Display

6. Custom templates must be saved in this directory:

A. Support
B. Projects
C. Templates
D. Root

ANSWERS: 1) T; 2) F; 3) C; 4) D; 5) D; 6) C
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