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  Formação em AutoCAD 14______________________________________________________
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Renderização

Notas:
Com o comando DVIEW consegue-se visualizar todo o desenho a 3 dimensões em vista de forma dinâmica, obtendo vistas em perspectiva rigorosa. Este comando deve ser usado quando se pretende ter uma visualização mais realista, para posteriormente obter imagens Renderizadas. Quando em perspectiva, o AutoCAD não permite modificar o desenho (não deixa fazer ERASE, COPY, MOVE, MIRROR, etc.). O comando tem as seguintes opções:

- Camera – Permite rodar a posição da câmara em relação ao ponto alvo. Pede dois ângulos, o primeiro, o ângulo que faz com o plano (inclinação), o segundo, o ângulo que faz com o eixo dos X (rotação).
- Target – É semelhante ao anterior, mas agora controlando a posição do alvo.
- Distance – Coloca o desenho em perspectiva rigorosa (o icóne que indica a direcção do sistema de eixos muda para uma caixa em perspectiva).
- Points – Define a localização do alvo e da câmara através da marcação de pontos. Esta deve ser a primeira opção a escolher quando se inicia o comando.
- Pan – Similar ao comando PAN, mas de particular importância, pois em perpectiva não se pode usar o comando PAN.
- Zoom – Como quando visto em perspectiva não permite usar o comando ZOOM, tem de se usar a opção Zoom para aproximar ou afastar o desenho. A opção disponibiliza uma barra para o controlo dinâmico do factor de aproximação (maior que 1) ou de afastamento (menor que 1).
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- Twist – Roda o desenho em torno do eixo dado pela linha que une a câmara e o alvo.
- Clip – Define planos de corte posterior e anterior (paralelos ao plano de vista) para limitar a visualização de entidades que estejam antes ou depois dos planos de corte. Mesmo tratando-se de sólidos, são cortados como se superfícies fossem.
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Casa a 3D com planos de corte anterior e posterior.


- Hide – Semelhante ao comando HIDE, bastante útil para o utilizador saber se, por exemplo, está fora de um modelo ou dentro dele (se for uma casa, se estivermos fora dela só vemos as paredes exteriores).
- Off – Retira o modo de perspectiva rigorosa (dando um valor para o factor de distância diferente de 1 torna a ficar em perspectiva rigorosa).
- Undo – Anula a última operação executada dentro do comando.
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Perspectiva paralela.
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Perspectiva rigorosa.

Quando ao executar o comando DVIEW se não se escolher nenhuma entidade significativa, o AutoCAD mostra uma casa a 3D para ajudar à visualização. 
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Casa a 3D por defeito se não for seleccionado entidades.

Não é necessário escolher a opção Points se o ponto de vista desejado for o que estiver activo antes de executar o comando (modificando depois o Zoom e a distância apenas).

O comando DDVIEW também pode ser usado em vista em perspectiva.

Com o comando SCENE pode-se criar cenas. Uma cena é uma vista do desenho com uma configuração de luzes escolhidas pelo utilizador. Primeiro deve-se criar uma vista (ou uma já gravada), depois só é necessário escolher as luzes que irão aparecer nessa cena (sendo necessário criar luzes antes de executar o comando), escolhendo All aparecem todas para essa cena.
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O comando LIGHT cria luzes, iluminando as faces de objectos. Na caixa de diálogo que aparece, pode-se controlar qual a intensidade da luz ambiente (o valor mais indicado para a intensidade de Ambient Light é de 0.3), como também a cor da luz projectada. 
Em North Location define-se a localização do Norte para o desenho. 
Quando não se sabe o nome de uma luz que esteja no desenho, usa-se Select para a seleccionar. New cria uma nova luz.
Modify altera a luz que estiver seleccionada.
Delete elimina a luz seleccionada.
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Caixa de diálogo do comando LIGHT.
O comando permite criar 3 tipos de luzes; foco de luz, ponto de luz, e luz distante. 

[image: image9.png]X





3 tipos de luz disponíveis.
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Ponto de luz.
O ponto de luz (Point Light) emite raios de luz em todas as direcções, como a luz de uma lâmpada, por exemplo. Depende do local onde se situa, pois perde intensidade com a distância.
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Luz distante.
A luz distante (Distant light) emite raios numa direcção, como a luz do Sol, por exemplo. Não diminui a intensidade com a distância, não depende então do local onde se coloca (pode-se por afastado do desenho para não estorvar).
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Foco de luz.
O foco de luz (Spotlight) projecta os raios em cone, a partir de uma origem, como a luz emitida por uma lanterna, por exemplo. Perde intensidade com a distância, precisando de controlar dois ângulos que definem os cones de luz.

Quando se cria uma nova luz deve-se escolher primeiro qual o tipo de luz que mais se adequa ao efeito pretendido. Depois definir a sua posição (Modify) em relação ao desenho. Se for um ponto apenas se define o ponto onde colocar, se for um foco ou uma luz distante precisa de dois pontos, para onde "apontar" e onde colocar (dar a direcção). Para verificar onde essa luz está selecciona-se Show. 
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Ponto de luz.
Marcando Point Light e carregando New cria um ponto de luz. Deve-se dar um nome para a luz no máximo com 8 caracteres. Pode-se mudar a cor da luz criada em Color. Em Attenuation pode-se controlar qual a atenuação da luz com a distância; None - não atenua com a distância (um objecto a uma distância superior de outro é iluminado com a mesma intensidade), Inverse Linear - atenua um pouco a intensidade (um objecto ao dobro da distância recebe metade da intensidade), e Inverse Square - atenua mais (um objecto ao dobro da distância recebe um quarto da intensidade). Em Shadow define-se se projectará sombra nas entidades.


Quando se deseja a luz com intensidade máxima dá-se um valor de 1 para a intensidade. Para dar a sua posição pode-se fazer de dois modos, ou dar a sua posição em coordenadas para azimute e latitude (sendo importante a situação do Norte do desenho, anteriormente tratado), ou dando dois pontos que definam o vector em Modify (sendo light direction TO o ponto final, e light direction FROM, o ponto de onde vem a luz). Em Sun Angle Calculator pode-se saber qual a inclinação (direcção) da luz solar para um dado local (Geographic Location) e data definidos (se essa luz for usada como Sol).
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Luz distante.
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Foco de luz.
Para a definição deste tipo de luz, o foco, é importante saber qual a sua posição, para onde aponta, qual o ângulo de luz intensa e qual o ângulo de luz total (se o Falloff for diferente e maior que o Hotspot, então haverá uma coroa de penumbra). Para ter um cone intenso de luz colocam-se os dois ângulos iguais. Também para este tipo de luz pode-se escolher qual a atenuação da luz com a distância.

Quando se pretende que uma luz deixe projectar raios luminosos (desligar), deve-se dar um valor de zero para a sua intensidade, não sendo necessário fazer o Delete dessa luz (uma luz é uma entidade como todas as outras, podendo-se fazer ERASE, COPY, MOVE, etc.).

Quando se pretende que uma luz projecte sombra (Shadow On), pode-se escolher qual o tipo de sombra que pode projectar essa luz, seleccionando Shadow Options aparece uma janela que permite a escolha de uma melhor ou mais fraca sombra. Se seleccionado Shadow Volumes/Ray Traced Shadows obtém-se as melhores sombras, mas mais demorado o cálculo. Se não for escolhido, tem-se sombras aproximadas por pixels, sendo melhores e mais demorado o cálculo quanto maior for o valor de Shadow Map Size.
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Opções da sombra.
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Sombras Volume/Ray Traced.
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Sombras Map.

Quando se quer que um desenho criado no AutoCAD fique com um aspecto realista, podendo depois ser usados para muitos fins, imagem realista de uma vivenda para um arquitecto, peça mecânica para um engenheiro, etc. deve-se usar o comando RENDER. 
Com o RENDER pode-se "pintar" entidades que tenham espessura, superfícies e sólidos, podendo ter texturas e transparências também. 
Quando executado o RENDER pode-se interromper os cálculos pressionando a tecla ESC.
Para retirar a visualização realista executa-se o comando REGEN.
O comando proporciona 3 tipos de Render; o Render - mais simples e mais rápido, não calcula sombras nem texturas ou transparências, o Photo Real - permite incluir texturas, sombras, imagens de fundo e nevoeiro, sendo mais demorado que o Render, e o Photo Raytrace - permite tudo o que o Photo Real faz, além de calcular reflexões, refracções e sombras detalhadas, sendo o mais demorado, mas também o mais rigoroso.


Em Rendering Type selecciona-se qual o tipo de Render a usar. Em Scene to Render pode-se pintar uma cena já gravada com uma configuração de luzes a usar (usando SCENE). Quando seleccionado Query for Selections pinta-se apenas as entidades que se seleccionarem depois. Em Crop Window pode-se pintar apenas uma janela criada com dois pontos dados pelo rato. Se seleccionado Skip Render Dialog, na próxima vez que for digitado RENDER já não aparece esta janela, fazendo a Renderização usando as últimas definições. Para ter de novo esta janela, digita-se o comando RPREF e retira-se a selecção Skip Render Dialog. 

Em Light Icon Scale controla-se o tamanho do ícone das luzes (25 poderá ser o mais indicado). Em Smoothing Angle controla-se qual o ângulo a partir do qual o AutoCAD considera que uma face é considerada uma aresta. Com Smooth Shade seleccionado consegue-se que as faces cilíndricas tenham um aspecto mais "redondo". Em Apply Materials usa os materiais que se escolheram para os objectos, senão, aplica o mesmo material a todos, o *GLOBAL*. Em Shadows calcula as sombras projectadas desde que pelo menos uma das luzes tenha a projecção de sombras seleccionado. Com Render Cache pode-se ter cálculos mais rápidos, pois guarda alguns cálculos em memória, isto se não se mudar o ponto de vista ou geometria do desenho.
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Caixa de diálogo do comando RENDER

Em More Options alteram-se algumas opções para a Renderização, dependendo do tipo de Render seleccionado. O destino da imagem obtida pode ser escolhido em Destination. Em Sub Sampling pode-se reduzir a escala da imagem obtida, ficando mais rápido, mas também com menos qualidade (1:8 tem a pior qualidade). O comando BACKGROUND pode ser executado a partir de Background. O comando FOG pode ser executado a partir de Fog/Depth Cue.
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Tipo Render.
Quando é seleccionado o tipo Render aparece uma caixa de diálogo onde se pode controlar a qualidade da Renderização, sendo Phong a melhor, mas mais demorada. Se Discart back Faces estiver seleccionado o AutoCAD não calcula a intensidade luminosa de faces que estejam escondidas por trás de outras, acelerando a Renderização.

A caixa de diálogo para o tipo Photo Real e tipo Photo Raytrace é semelhante. Pode-se controlar a suavidade das arestas em Anti-Aliasing. Minimal apresenta as arestas em "escada", High tem melhor efeito, mas é também o mais demorado. Quando se aplica uma textura sobre um objecto em que a textura é maior que o objecto, pode-se controlar a forma de projecção em Texture Map Sampling.
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Tipo Photo Raytrace.

O destino da imagem pode ser o ecrã (Viewport), ficando com as cores que o sistema operativo estiver na altura. Depois pode ser gravada para o disco se usado o comando SAVEIMG.
Pode ser transportada para uma nova janela (Render Window), onde depois pode ser gravada em Save, imprimida em Print, copiada para o Clipboard em Copy, ou modificar a dimensão da imagem e profundidade da cor em Options.
Pode também ir directamente para um ficheiro (File), podendo ser seleccionado More Options, onde se pode escolher qual o formato, dimensão e número de cores da imagem obtida (ter em atenção que diferentes tipos de formato têm número de cores disponíveis diferentes).
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Janela Render Window.
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Caixa de diálogo de More Options para File.

Para ter melhores imagens quando se pintam superfícies ou sólidos curvos deve-se dar um valor para FACETRES maior que 0.5 (o ideal é entre 2 e 6, aumentando o tempo de processamento com o aumento desse valor), fazendo com que diminuam as arestas aproximadas a rectas. 

Pode-se aplicar texturas a objectos com RMAT. Pode-se escolher entre os materiais que o AutoCAD tem em Materials Library, modificar um desses materiais em Modify, ou até criar um novo em New. Depois deve-se aplicar esses materiais aos objectos pretendidos com Attach , ou com By ACI (para objectos com a mesma cor ficarem com o mesmo material), ou com By Layer (para objectos no mesmo layer ficarem com o mesmo material). Com Select pode-se saber qual o material que um certo objecto no desenho tem. Para retirar um material a um objecto usa-se o Detach.
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Comando RMAT

Pode-se ter uma visualização prévia do material a ser usado em Preview.
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Comando MATLIB.


Em Materials Library pode-se escolher materiais já criados da Library List para importar para o desenho com Import. Com Purge retira-se um material que não seja usado no desenho, que esteja seleccionado, ficando o desenho menos "pesado". Cuidado ao fazer Delete, pois pode-se apagar um material da libraria do AutoCAD, se um deles estiver seleccionado. Esta caixa também pode ser acedida através do comando MATLIB.

É permitido mudar as definições de um material. Podendo-se alterar:
- a cor principal - Color, cor do material for a das zonas de brilho. Se usada uma imagem para Bitmap Blend o material pode ficar menos ou mais com esse aspecto, dependendo do valor entre 0 e 1 dado, respectivamente.
- ambiente - Ambient, cor quando sujeita apenas à luz ambiente.
- reflectida - Reflection, cor reflectida pela zona de brilho.
- rugosidade - Roughness, tamanho da zona brilhante, sem tornar o material rugoso.
- transparência - Transparency, transparência do material. Se usada uma imagem para Bitmap Blend o material pode ficar menos ou mais misturado com o ficheiro, sendo as zonas brancas do ficheiro opacas e as pretas transparentes (Opacity Maps).
- refracção - Refraction, refracção do material.
- relevo - Bump Map, relevo do material, sendo as zonas brancas do ficheiro escolhido as zonas mais salientes do material.
 
[image: image27.png]Modify Standard Materi

Material Name: |LITEWOOD SHINGL
Aibutes
& Colr/Patiem Value: 100 >
© Ambient B
™ Byall r r
€ Reflcton e o] >
rean « >
" Roughness @ oo ] 4 Lo 3 B
Blue: oo |« > —
P I ColoSysten  [rop =] Cube =
 Refaciion
Bitmap Bleng: [1.o0 _|»|  adustBimap
 Bump M
B> FieName:  [SHNGLZTGA Find il

o cove |t |





[image: image28.png]ap Placement
Tiing
mi & ILE
 CROP.
Figven
| ol || Jewe =
it [0.000000 U om0 | ¥
Scale: [1.000000 U [omom v

I™ Mairtain Aspect Ralio

oK

Caresl

Lt |




Para tornar a textura mais "repetida" pode-se alterar a escala (Scale) do Bitmap em Adjust Bitmap. Dando valores maiores do que 1 aumenta o padrão (diminui o aspecto da textura). Tile repete a imagem formando um padrão.
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Ao fazer Attach by Layer pode-se dar um material para todos os objectos que estejam nesse Layer, seleccionando o material e o Layer para o qual estará definido e fazendo depois Attach.

AutoCAD permite também incluir elementos paisagísticos no desenho, árvores, pessoas, etc. Estas são apenas visualizadas quando se faz a Renderização. Em Height controla-se o tamanho do elemento a incluir. Em Position define a posição a tomar no desenho. Se Crossing Faces estiver seleccionado torna o desenho mais real, pois dá-lhe um efeito mais 3D, aparecendo no desenho como dois triângulos (um triângulo para Single Face). Com View Aligned o AutoCAD alinha o elemento com o ponto de vista.
Estes elementos podem ser tratados como as entidades vulgares, ser copiadas, movidas, etc.
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Comando LSNEW.

Com o comando LSLIB pode-se criar novos elementos, apagar elementos, ou modificar. Quando se escolhe Modify, é executado o comando LSEDIT, permitindo modificar um elemento. Ao criar um novo elemento pode-se procurar uma imagem (Image File) que será o novo elemento a adicionar, e escolher uma imagem para lhe dar a opacidade desejada, sendo feita com base na primeira, mas com a cor branca nos pixels que devem aparecer (imagem), e preta para os que serão transparentes (cor de fundo). As imagens devem estar no formato TGA.

Pode-se incluir no desenho uma imagem de fundo, aparecendo quando se inicia a Renderização. Se não se quiser uma imagem, também se pode ter como fundo apenas uma cor (Solid), ou um gradiente de cores (Gradient).
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Comando BACKGROUND.


Também se pode incluir o efeito de nevoeiro com FOG. Enable Fog adiciona o nevoeiro. Pode-se alterar a cor do nevoeiro, a distância a partir da qual se inicia o efeito (se 0 em Near Distance aparece o nevoeiro desde o ponto de vista), a distância onde termina o nevoeiro (se 1 em Far Distance vai até à imagem de fundo). Em Near Fog Percentage controla-se a percentagem de nevoeiro para a distância inicial, em Far Fog Percentage controla-se a percentagem de nevoeiro para a distância final.
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Quando o aspecto das texturas não é o melhor, não aparecendo a imagem da textura paralela à superfície do objecto, deve-se alterar as coordenadas de projecção para esse objecto com SETUV. Neste comando pode-se informar o AutoCAD se a projecção pretendida para a entidade é planar (como uma folha), cilíndrica (a textura acompanha a curvatura do objecto), esférica (para uma entidade esférica) ou sólida (a textura repetida nas 3 direcções do objecto). 
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Em Adjust Coordinates pode-se definir qual o sistema de coordenadas a usar para a projecção da textura (podem ser diferentes do UCS actual). Se for um sistema de coordenadas complexo, pode-se escolher os pontos que definem as direcções nesse objecto em Pick Points.
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Dois exemplos de sólidos em que o primeiro tem uma textura sólida e o segundo uma textura planar. 
A primeira textura é repetida nas 3 direcções, a segunda tem linhas da mesma cor para a altura, 
repetindo a textura como se fossem folhas sobrepostas.

Comandos:

DVIEW
View > 3D Dynamic View


Permite visualizar o desenho em perspectiva rigorosa.

RENDER
View > Render > Render
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Permite criar imagens realísticas, “pintando” os objectos do desenho.

SCENE
View > Render > Scene
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Criar cenas a partir de vistas gravadas, com as luzes pretendidas para essa cena.

LIGHT
View > Render > Light
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Cria luzes.

RMAT
View > Render > Materials
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Permite definir materiais ou texturas para superfícies, regiões e sólidos.

MATLIB
View > Render > Materials Library
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Gere os materiais a serem usados no desenho.

SETUV
View > Render > Mapping
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Altera o sistema de coordenadas de projecção dos objectos seleccionados.

BACKGROUND
View > Render > Background
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Permite inserir uma imagem de fundo quando feita a Renderização do desenho.

FOG
View > Render > Fog
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Permite incluir o efeito de nevoeiro quando feita a Renderização do desenho.

LSNEW
View > Render > Landscape New
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Permite inserir no desenho elementos paisagísticos.

LSEDIT
View > Render > Landscape Edit

[image: image45.png]



Altera as características dos elementos paisagísticos seleccionados.

LSLIB
View > Render > Landscape Library

[image: image46.png]



Permite criar, apagar e modificar elementos paisagísticos de uma libraria.

RPREF
View > Render > Preferences

[image: image47.png]



Apresenta a caixa de opções para fazer Render.

STATS
View > Render > Statistics

[image: image48.png]



Mostra a informação relativa à última Renderização efectuada.

SAVEIMG
Tools > Display Image > Save


Permite gravar a imagem criada pela Renderização presente no ecrã para o disco.

Estão assim terminados os resumos do AutoCAD 14, se tiveres alguma dúvida, não hesites em enviar um email para n_fernandes@rocketmail.com ou n.fernandes@mail.pt 

Nuno Fernandes

http://pagina.de/NunoFernandes
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Formador: Pedro Damásio 
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