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Lesson 27
Top- Down Assembly

Learning Objective

In this lesson, the user will create a top-down assembly.  A top-down assembly means that all the parts are
created in the same file.  A top-down approach allows the designer to check for interference and make
changes quickly on the fly.

When you first open Inventor, it gives you four choices...to build an assembly, to create a drawing, create a
presentation or to build a part.

Inventor provides users the flexibility to create an assembly using the top down approach or the bottom up
approach.

Let’s create a hinge assembly using the top down approach and open an assembly drawing.  We start by
opening an assembly file.

Inventor opens with a blank screen.

Part 1- Hinge Bracket

    

We can create a New Component using four methods:

♦  Go to the Menu and select Insert-> New Component
♦  From the Panel Bar select -> Create Component
♦  From the Assembly toolbar->Create Component
♦  Right click in the graphics window and select ‘Create Component’
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Now a new dialog box comes up.  We name our component ‘bracket’ and note it will automatically create
the external drawing file so the part can be re-used in future assemblies.

At this point, we have named our drawing file, defined it as a part, selected a standard template, and located
it in our working directory, we can move on.

Note that the Assembly has it’s own origin, axes and planes.  Each part is assigned an origin, plane and
axes as well.
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Exit from the sketch.
Select the XZ Plane and start a New Sketch.

Create the sketch shown.  Add geometric constraints as needed.
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Select ‘Finish Sketch’.
Activate the Features toolbar and select ‘Extrude’.
Set the Distance to 5.75.
Press ‘OK’.

TIP:  If you select ‘Finish Edit’ that means you are finished creating your component.
Inventor to returns you to the top assembly.  To return to editing the component, select the
component in the browser , right click and select ‘Edit’.  If you wish to edit the part outside
the assembly, right click and select ‘Open’.



Top Down Assembly

Page 27-5

Create Offset Plane

Select the Work Plane tool from the Features toolbar.
Select the face indicated.
Drag the plane forward and enter a value into the text box of .35

Select the New Work Plane.
Right click and select ‘New Sketch’.

Select this face
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Draw a rectangle and dimension as shown.

Switch to an isometric view.

To make a cut, select the second button in the middle column on the ‘Extrude’ dialog box.  The top button
is a ‘Join’, the second button is a ‘Cut’, the third button is ‘Intersect’, and the fourth/bottom button is
‘Surface’.  Pass the mouse near these buttons and they will show the commands.  The arrow color changes
depending on the mode selected. A ‘Cut’ will preview as red.  A ‘Join’ will preview as green.  An
‘Intersect’ will preview as blue.

0.80

0.95
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Turn off visibility on the Work Plane.
Select the Work Plane in the browser.
Right click and select ‘Visibility’.

 

Select the top plane as shown.
Right click and select ‘New Sketch’ or enter Sketch mode by selecting the Sketch button on the Command
toolbar.
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Place a Point, Hole Center so it is located concentric to the arc.

Select the Hole tool from the Features toolbar.

TIP:  Setting the Termination to Through All will cause the hole to go through the top AND bottom of the
part.
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Set the Distance to 0.8
Set the Type to
Drill/Ream.

Select the Threads tab.
Enable Tapped and Full
Depth.
Set Thread Type to
ANSI.
Enable Right Hand.

Select the Size tab.
Set the Nominal Size to
0.625.
Set the Pitch to 5/8-11
UNC.
Set the Class to 2B and
the Diameter to Minor.

Select the Options tab.
Enable Flat Drill Point.

Press ‘OK’.
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Select the Face indicated and start a new sketch.

We want to add a pin to the bottom flange.  This pin is a press-fit part, so if we were really going to play
mechanical designer, we would show a hole and then create another assembly drawing with the two parts
(pin & bracket), but in the interest of keeping it simple, we’ll just create it as an assembly and handle it as a
note in the detailed drawing of the bracket part.

Select the bottom flange as shown by picking on it.  A double-left pick will highlight it in green and then
right click to bring up the pop-up menu.
Select ‘New Sketch’.

Draw a circle with a diameter of 0.5.
Locate it so that it is concentric to the arc.
Extrude as a ‘Join’.  Set the Distance to 0.3.
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Select the face indicated and start a ‘New Sketch’.

Project Geometry

Use the existing edge to create a new sketch.
Select the Project Geometry tool from the Sketch toolbar.
Then select the top edge of the cylinder.

There is no need to dimension or constrain projected geometry as it is dimensioned and constrained by its
source sketch.

Extrude using Join.
Set the Taper to –30.
Set the Distance to 0.35.

Note that the preview shows you the taper direction.  If you want the taper to go in, make it a negative
number.  If you want the taper to go out, make it a positive number.  Set the distance to .35 as shown.

Press ‘OK’.

TIP:  In your Application Options under the Sketch tab, you can enable ‘Automatic reference edges for new
sketch.  This will automatically project any geometry collinear to the new sketch plane.  The default is for this
to be enabled.
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Our completed bracket.
Save the file.

Pressing the ‘Return’ button on our Command toolbar will return us to the Assembly environment.

Part 2- Hinge

Select the ‘Create Component’ tool to start the next file.

TIP:  In an assembly file, any planar surface of any part can be used as a sketch plane.



Top Down Assembly

Page 27-13

Fill out the dialog box as shown:

New File Name Hinge.ipt
File Type Part
Constrain sketch plane to selected face Disabled

Select the face indicated to be used as the initial sketch plane.

You can change your viewpoint by selecting the Look at option in your View toolbar and then selecting
your sketch plane.
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Inventor automatically turns all components other than the one currently being edited ‘Opaque’.  This
option is set in Application Options under the Assembly tab.  Enabling ‘All’ will turn off Opacity and make
all parts appear according to the current View setting.

To assist creating the hinge, we can turn the bracket visibility to OFF.  Get out of ‘Edit Mode’ by clicking
on each part, right-clicking and selecting ‘Finish Edit’.  Then pick on the bracket or select it in the browser
and highlight, right click and disable the visibility option.

Create the sketch shown.
Add Equal Constraints to the lines indicated.

5.75

5.753.40

1.80

TIP:  We can control visibility of parts by selecting the part in the browser or by selecting the part in the
drawing window.
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Right click and select  ‘Finish Sketch’.
Switch to an isometric view.

Select the Extrude tool.

Modify the distance and enter a value of 1.25.  Then press ‘OK’.

Select the top plane as shown so that we can add a hole.

Your extruded part should look like the figure shown
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Select the Point, Hole, Center Tool
on the left hand toolbar and locate
your hole as shown.

Now, select the Hole tool located in
the upper left of the screen.

TIP:  See if you can use the ‘Show Dimensions’ option of the Edit Dimension box to add the dimensions.
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Set the Distance to 1.75.
Set the Type to Drill/Ream.

Select the Threads tab.
Enable Tapped and Full Depth.
Set Thread Type to ANSI.
Enable Right Hand.

Select the Size tab.
Set the Nominal Size to 0.625.
Set the Pitch to 5/8-11 UNC.
Set the Class to 2B and the Diameter to
Minor.

Select the Options tab.
Enable Flat Drill Point.

Press ‘OK’.
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Rotate the part so we can select the face indicated for a new hole.

Copy Feature

Locate the hole just created in the browser.
Right click and select ‘Copy’.

Select the face indicated.
Right click and select ‘Paste’.
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The Paste Features dialog box appears.
Press ‘Finish’.

The second hole is placed, but it is not constrained.

TIP:  When you copy a feature you can make it Independent or Dependent.  Dependent features get their
dimension values from the source feature.
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Select the sketch in the browser.
Right click and select ‘Edit Sketch’.

Relocate the Point, Hole Center correctly.
Exit the sketch.

Edit Hole

Locate the second hole in the browser.
Right click and select ‘Edit Feature’.

Set the Distance to .75.
Set the diameter to 0.51.
Set the Type to Drill/Ream.

Disable the Tapped.

Press ‘OK’.
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Shell

Click the Shell tool.

Change the View to Wire Frame for easier selection.

Remove this face
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Add Fillet

Add fillets to the small extrusion.

Set the fillet radius to 0.625 for the outer edges.



Top Down Assembly

Page 27-23

The inner fillet can use a formula.  Type 0.625 – 0.120 in for the radius.

Our assembly so far.

Press the Return button or double-click on the assembly name in the browser to return to Assembly mode.



Top Down Assembly

Page 27-24

Part 3 – Bolt

Time for the third part, the bolt that will fasten the hinge and bracket together

We can use the Fastener Library to insert a bolt.

Go to Tools->Fasteners->Insert Fastener.

Go to ANSI->Screws and Threaded Bolts->Hex Head Types.
Select  Hex Cap Screw- UNC.

Your tapered pin!
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Select 5/8”-11 for size.
Then press ‘Next’.

Select a length of 2.25 inch.
Then press ‘Finish’.
To place in our assembly, pick a point in the drawing window.  Then right click and select ‘Done’.
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Grounding Parts

We can disable/enable the grounding by selecting the part in the browser or picking the part in the drawing
window.  Then right click and enable/disable Grounded.

So we should see a pin next to the bracket.
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Assembling the model

Add the constraint for the hinge and the bracket by using ‘Insert’ and selecting the parts.

Add an insert constraint between the bolt and the bracket.

Our assembled hinge.

A side view shows us that the parts do not fit together properly.

1

2
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Modifying a Constraint

We start by editing the insert constraint between the bottom of the bracket and the bottom of the hinge.
Locate the Insert Constraint in the browser and highlight.
A small edit box appears on the left bottom of the browser.
Change the Offset to 0.250.
Press ‘ENTER’.

The bottom of the bracket is now flush with the bottom of the hinge.
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Our hinge is now situated properly in the vertical direction.  We still have some interference between the
hinge and the bracket.

Interference Checking

Go to Tools->Analyze Interference.

Select the hinge as Set #1.  Select the Bracket as Set #2.  Then press ‘OK’.

Interference
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A window will come up reporting the interference issue.

When analysis is complete, the number of instances of interference and their combined volumes, if
applicable, display in a message. Click OK to dismiss the dialog box or click the More button to show the
analysis report in table form. To adjust width, drag column margins.
Item Lists the interference volume in numerical order, according to the browser order.

Part 1 Lists the file name of the part in Set #1 that interferes with a part in Set #2. If the part is a
member of a subassembly, shows both the file name and the part number.

Part 2 Lists the file name of the part in Set #2 that interferes with a part in Set #1. If the part is a
member of a subassembly, shows both the file name and part number.

Centroid Lists the XYZ coordinates, relative to the assembly origin, of the interference centroid.
Volume Lists the volume of the interference found.

You can modify parts to eliminate the interference. You can either print the interference report or copy it to
the clipboard and open it in a text editor or spreadsheet.

Offset Work Plane
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We see that the interference is due to the offset plane being too far forward.

Editing Parts in an Assembly

In order to correct this, we need to edit the bracket.

The user can edit a part inside of an assembly by:
♦  Highlighting the part in the browser, right click and select ‘Edit’.
♦  Pick on the part in the drawing window, right click and select ‘Edit’.
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All the other parts automatically grey out to allow us to concentrate on the part being modified.

Modifying a Work Plane

To modify the work plane offset value:
♦  Highlighting the work plane in the browser, right click and select ‘Redefine Feature’.
♦  Pick on the work plane in the drawing window, right click and select ‘Redefine Feature’.

Select the front plane and set the Offset to 0.10 in.

It now looks like our assembly has a decent fit with no interference.
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Degrees of Freedom

We can use the Degrees of Freedom tool to see if our assembly is constrained properly.
Go to View->Degrees of Freedom.

We see a rotation axis indicated.



Top Down Assembly

Page 27-34

Moving an Assembly

Switch to an isometric view.  Change the view to solid.
Place the mouse on top of the hinge. Hold the left mouse button down and move the mouse.
You should see the hinge swing back and forth.

You’ll notice that the hinge can rotate into and through the bracket.

Save the assembly as ‘hinge-assy.iam’.
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